Weather Routing - Land collision

VRTool software support forum

Weather Routing - Land collision

Postby S-B-T-C » Mon Feb 04, 2013 6:54 pm

Hello Omar,

I seem to be having problems with using the weather routing facility when sailing close to land.

I get the following error message -
isochrone=0:10
Not pf1bit (C:\..\vrtool\LandCollisionDetector.pas, line 58)
----
calculation finished
calc time= 0.08 sec
LGC dist= 55.6 NM
shortest= 0.0 NM
longest= 0.0 NM
points=1
successfull tracks=1
best time= 0d 00:00:00

I have tried looking for the file mentioned in the error message but am unable to find such a folder listed, nor any file named as such in any folder on my PC.
I have tried removing VRT and then downloading and doing a complete new installation and now my weather routing facility doesn't work at all if land collision is selected.

Can you assist?
S-B-T-C
 
Posts: 3
Joined: Thu Nov 15, 2012 9:27 am

Re: Weather Routing - Land collision

Postby omar » Tue Feb 05, 2013 10:07 am

S-B-T-C wrote:Not pf1bit

The error means your land collision detection bitmap is in the wrong format.

Implementation of land collision detection uses a large chart bitmap as reference.
To minimize memory usage, vrtool uses a monochrome, one bit-per-pixel BMP file format.

Default file is monoBmpGSHHS_24k12k.bmp
This is a rendering of a GSHHS chart from vrtoutoulz,
generated by vrtool itself (there is a [btn] for that)

You can edit the bmp using Windows Paint or Photoshop.
Make sure you maintain the one bit-per-pixel BMP file format.
User avatar
omar
Site Admin
 
Posts: 491
Joined: Thu Apr 30, 2009 11:00 am

Re: Weather Routing - Land collision

Postby S-B-T-C » Tue Feb 05, 2013 1:34 pm

:) Thank you for your reply, seems I managed to get it working by loading a new nav file from scratch.
Because I now have it fully working it seems my nav file got corrupted.

I did consider that the .bmp image might be problematic and had previously created a new bitmap and overwrote the original file, but that wasn't the problem in this case as mentioned.

;) If at first you don't succeed, try and try again.
S-B-T-C
 
Posts: 3
Joined: Thu Nov 15, 2012 9:27 am

Re: Weather Routing - Land collision

Postby Billbo » Mon Mar 18, 2013 9:05 am

Hi Omar,
I have succeeded in getting the polars working and the weather routing works fine. I am now trying to get the land collision operating , I have read all the posts on the subject but I can't get the monoBmpGSHHS_24k12k.bmp file to load. If I click on Load BMP nothing happens. I can go into the VRTool folder and the file is there, I can open it using Paint, but it won't load in VRTools....
Billbo
 
Posts: 28
Joined: Tue Jun 15, 2010 4:46 am

Re: Weather Routing - Land collision

Postby draft » Thu Oct 23, 2014 12:00 am

Hi,

I was having this "no pf1bit" problem and fixed it by openning the land collision detection window and replacing the bitmap filename with a fully qualified path to the bitmap. In my case it goes like this: C:\Program Files (x86)\VRTool\monoBmpGSHHS_24k12k.bmp
Afterwards just click load BMP.
draft
 
Posts: 1
Joined: Wed Oct 22, 2014 11:56 pm


Return to VRTool Forum